No SMS failures have been observed since 1:45 PM CT.
Posted Oct 20, 2025 - 16:00 CDT
Monitoring
We are experiencing intermittent delivery of outbound SMS with our provider - Twilio. This is due to ongoing performance issues with Amazon's AWS service. Some SMS are going out. We are continuing to monitor the incident.
Posted Oct 20, 2025 - 12:05 CDT
This incident affected: Notifications Delivery Service.