U.S. Call Delivery Disruption

Incident Report for AlertOps

Postmortem

Incident Window: 5:50 AM CT – 8:00 AM CT
Impact: U.S. outbound and inbound calls were failing for a portion of customers due to an outage within one of our telephony service providers.

What Happened

At 5:50 AM CT, our monitoring detected a spike in failed call attempts across U.S. routes. The root cause was an outage within one of our upstream telephony service providers. Due to the provider’s disruption, calls routed through that provider were unable to connect.

How We Responded

  • Immediately escalated the issue with the provider and began internal investigation.
  • Redirected call traffic to a secondary backup provider.
  • Validated successful call delivery and system performance after the switch.
  • Continued monitoring to ensure there were no residual effects after the failover.

Service was fully restored by 8:00 AM CT.

Posted Nov 18, 2025 - 09:49 CST

Resolved

Service Restored
Time: 8:00 AM CT

Our team has rerouted traffic to a backup provider, and U.S. call delivery has now been restored.

We are continuing to closely monitor system performance to ensure stability. No further impact is expected at this time.

We appreciate your understanding and will follow up with a detailed post-incident summary.
Posted Nov 18, 2025 - 09:49 CST

Investigating

We are currently investigating an issue affecting U.S. call delivery. One of our telephony service providers is experiencing an outage, resulting in failed or undelivered calls for some customers.

Our engineering team is actively monitoring the situation and working to mitigate the impact. Further updates will be provided as we learn more.

Thank you for your patience while we work toward a resolution.
Posted Nov 18, 2025 - 05:45 CST
This incident affected: Notifications Delivery Service.